Ubuntu 10.04(Lucid)のGMA 500 Poulsbo対応状況

(Last Updated On: 2010年5月2日)

先日購入したVAIO Xに,Ubuntu10.04を入れた.
結論から言うとPoulsboのドライバが入れられなかった.
GMA 500のネットブックお持ちの方は,まだ9.10使ってたほうがよさそうです(2010-05-02現在).

2010-05-12追記
スクリプトが公開されました

2010-05-19追記
僕のVAIO Xに,スクリプトを使ってインストールできました.
VAIO P,Xでは,grub2の書き換えが必須です.
挑戦するかたは,自己責任でお願いします.

9.04から,PoulsboのドライバがLaunchpadで公開されていた

9.10以降も(入れるのに苦戦するものの)使えていた

(2010.4半ば) Ubuntu 10.04でPoulsboが使えない.Jolicloudでは使えるのにどうしてだ!(Forumより)

ソースコード自体がuglyで対応が難しい

Karmic対応のshをLucid用にしたshが公開された

動かない人続出(僕も試してみたのですが動きませんでした)

一方Mandriva cooker(debianで言うところのtestingやsid)では,Mon, 26 Apr 2010に改良されたソースコードがパッケージで配布されていた

Lucidではそのまま使えない

Lucid用にMandrivaからcherry-pickingして作り直してみたけどXが起動しない

2010-05-05追記
ubuntuforums.orgのlucazadeさん,jbernardoさんがドライバを直してくれた.どうやら/usr/libが/libになっていたらしい.

2010-05-07追記
Karmicでは動くものの,依然,Lucidでは動かない

ソースコードの改良が続く

Lucidで5秒間動くようになった

notification-areaとnotify-osdを消せば30秒動くことが判明した.

2010-05-09追記
まだ完璧ではないものの,動くようになったようです(/etc/X11/xorg.confを編集する必要があります)

2010-05-10追記
改良版シェルスクリプト(temporary版)ができたようです.

2010-05-11追記
Ubuntuのwiki(HardwareSupportComponentsVideoCardsPoulsbo)のLucidの項目が更新されました.
動いた報告が何件か上がってます.VAIO P,Xでは,今回もgrub2の書き換えが必要なようです
ソラオチは今週末以降作業します.

参考
Poulsbo on Mandriva with X server 1.7
http://blino.org/blog/mandriva/poulsbo-xserver1.7.html

When will ubuntu Lucid 10.04 support Intel GMA500 "Poulsbo" video hardware?
http://ubuntuforums.org/showthread.php?t=1453445

Guide to Get the Best Performace from the GMA 500
http://ubuntuforums.org/showthread.php?t=1229345&highlight=gma500&page=50

HardwareSupportComponentsVideoCardsPoulsbo
https://wiki.ubuntu.com/HardwareSupportComponentsVideoCardsPoulsbo/

1 thought on “Ubuntu 10.04(Lucid)のGMA 500 Poulsbo対応状況

  1. ピンバック: Tweets that mention 空落科技 - Ubuntu 10.04(Lucid)のGMA 500 Poulsbo対応状況 -- Topsy.com

コメントを残す

メールアドレスが公開されることはありません。