WordPressの自動アップデート

public_html 以下にwordpress を展開しただけだと

要求された操作を実行するためには、接続情報が必要です。

というエラーが出て自動アップデートが実行できない.

chmod -R 777 ./wordpress しても上記エラーが出るので諦めていたのだが,chown -R www-data ./wordpresswordpress の所有権をapacheにしたら自動アップグレードできるようになった.

参考URL:WordPressで「要求された操作を実行するためには、接続情報が必要です」と出る原因とその対処法メモ

追記@2011-02-26 うさぎ亭主さんのご指摘により一部訂正しました.